Having technical issues? It could be your browser!

We recommend using Google Chrome if possible.

Operating System: Courses in Elevate require the following systems to operate properly.  You may be able to register, but may not be able to access, or even see, the components on older versions: Windows 7 or later, Mac OS X 10.9 or later, Chrome 60 or greater, Firefox 52 or greater, Edge 14  or greater, Safari 10 or greater, iOS 10 or greater, Internet Explorer 11.

If trying a different browser does not resolve the problem, please email Ansley StPierre (astpierre@agrisafe.org).